Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Plugins no longer working since the v3.0.5 upgrade

  1. #1
    pepsi's Avatar
    Join Date
    Mar 2009
    Location
    New Zealand
    Posts
    14,881
    Thanks
    91
    Thanked 806 Times in 721 Posts

    Post Plugins no longer working since the v3.0.5 upgrade

    I know we have been getting a lot of comments about certain plugins which were working before, but no longer work with ClassiPress v3.0.5.x, so I thought I would create this post to explain further, saving me repeating the same response on this topic...

    Here's the deal with plugins... When WordPress 3.0 was released, it included many new features, such as the ability to use custom post types. ClassiPress has now been upgraded to follow suit, also making use of custom post types (as do our other themes such as JobRoller).. We changed from "post" to "ad_listing" as the post type, and plugins that have been around prior to WP 3.x only look for "post" since that's all WP supported up to 3.x. This is basically why it worked before and doesn't now.

    The problem is, not all plugins have been upgraded by their authors to support the use of these custom post types, meaning they are no longer compatible with ANY theme that is using them. Sure, you can look to edit these yourself if you wish, but at the end of the day, these plugins are not officially supported.

    In some cases, if you search Google you may find solutions for workarounds related to specific plugins, other times you may not. For example I already came across one which gives a solution to the problem with the Google XML sitemap plugin. It's totally up to you if you want to apply fixes to get these plugins working, but this is at your own risk.

    Ultimately we're on the cutting edge and rolling out brand new features only supported in WP 3.x, so if you have a plugin that worked before, and doesn't now, you'll either need to find a fix for it yourself, or contact the plugin creator/check their site to see if an upgrade is imminent. AppThemes will not be able to assist with this.

    ClassiPress was making use of a couple of plugins which fall into this category, so we will be looking for alternative methods for the print this post and email this post functions. The plugin author is no longer upgrading any of their plugins so in this instance we know they won't be providing a solution. If these functions are important to you, you could perhaps look at using the Sociable for WordPress 3.0 plugin which includes print and email icons which work fine.
    Last edited by pepsi; December 12th, 2010 at 06:33 PM.
    Please help our moderating team work more efficiently by not sending us support questions via PM. You can read more about how AppThemes support works here. Thank you.

  2. The Following 6 Users Say Thank You to pepsi For This Useful Post:

    Fanatic (November 26th, 2010), JenniferR (November 28th, 2010), jithin (February 9th, 2012), mazumaind (November 26th, 2010), mtgmantx (December 4th, 2010), salota8550 (January 2nd, 2011)

  3. #2
    tordehax's Avatar
    Join Date
    Nov 2010
    Location
    Germany
    Posts
    104
    Thanks
    1
    Thanked 3 Times in 3 Posts
    You must be an AppThemes customer and logged in to view this response. Join today!

  4. #3
    Veteran spymare's Avatar
    Join Date
    Aug 2010
    Location
    Denmark
    Posts
    871
    Thanks
    16
    Thanked 82 Times in 61 Posts
    You must be an AppThemes customer and logged in to view this response. Join today!

  5. #4
    pepsi's Avatar
    Join Date
    Mar 2009
    Location
    New Zealand
    Posts
    14,881
    Thanks
    91
    Thanked 806 Times in 721 Posts
    You must be an AppThemes customer and logged in to view this response. Join today!
    Please help our moderating team work more efficiently by not sending us support questions via PM. You can read more about how AppThemes support works here. Thank you.

  6. #5
    Senior Member frcamp's Avatar
    Join Date
    Nov 2010
    Location
    United States
    Posts
    192
    Thanks
    3
    Thanked 10 Times in 8 Posts
    You must be an AppThemes customer and logged in to view this response. Join today!

  7. #6
    Marketplace Seller ahikmahin's Avatar
    Join Date
    Aug 2010
    Location
    Australia
    Posts
    504
    Thanks
    32
    Thanked 52 Times in 42 Posts
    You must be an AppThemes customer and logged in to view this response. Join today!

  8. #7
    Amateur likeitbuyit's Avatar
    Join Date
    Oct 2010
    Location
    Australia
    Posts
    14
    Thanks
    0
    Thanked 2 Times in 1 Post
    You must be an AppThemes customer and logged in to view this response. Join today!

  9. #8
    Veteran bluecafe's Avatar
    Join Date
    Apr 2010
    Location
    Berlin
    Posts
    1,563
    Thanks
    58
    Thanked 359 Times in 273 Posts
    You must be an AppThemes customer and logged in to view this response. Join today!

  10. #9
    Veteran bellboy's Avatar
    Join Date
    Apr 2010
    Location
    Tokyo, Japan
    Posts
    515
    Thanks
    132
    Thanked 43 Times in 36 Posts
    You must be an AppThemes customer and logged in to view this response. Join today!

  11. The Following User Says Thank You to bellboy For This Useful Post:

    mr_green (December 2nd, 2010)

  12. #10
    Marketplace Seller thesyndicate's Avatar
    Join Date
    Aug 2009
    Location
    The Matrix
    Posts
    1,816
    Thanks
    15
    Thanked 52 Times in 51 Posts
    You must be an AppThemes customer and logged in to view this response. Join today!


    I love to help out you out but please read this first Have you tried to install in a root domain? Have you tried to Resave permalinks? Have you tried to disable all plug in? Have you tried the default theme of Wordpress?

    ++ If the issue is fixed consider closing the thread and change to solved, thank you for helping us helping you. ++

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Google Maps Stopped working for Jamaica since upgrade
    By xhanubis in forum Report ClassiPress Bugs
    Replies: 1
    Last Post: August 28th, 2010, 01:02 PM
  2. [SOLVED] Used image uploads stopped working after upgrade
    By shightouch in forum Report ClassiPress Bugs
    Replies: 5
    Last Post: August 21st, 2010, 05:50 PM
  3. MYSQL Queries Longer than 15 seconds
    By hiro in forum ClassiPress General Discussion
    Replies: 2
    Last Post: August 5th, 2010, 04:34 PM
  4. Images are not working after upgrade
    By sushubh in forum Help Using ClassiPress
    Replies: 14
    Last Post: April 23rd, 2010, 03:35 PM